Monday, March 5, 2012

Install Beagleboard XM Ubuntu 11.10 with GUI

(LAST UPDATED 1/19/2013) - New blog that superseeds this one...in many ways check it out

       
         So this quick run through will be to illustrate how to get Ubuntu 11.10 and a GUI running on the Beagleboard XM.  Graphical User Interface (GUI, pronouced "Gu eee") is the interface that is used on most computers that does not consist of a Terminal or command prompt.

I do all my setup on my Windows 7 64-bit laptop (HP elitebook, i5 2nd gen). I have Virtual Box installed running Ubuntu Desktop.

One of the first things I install is VirtualBox Guest Additions Installations. This allows me to copy and paste between windows and virualbox. Go up to devices->install guest additions. It will prompt you for your Ubuntu root password. Then just wait. When finished reboot Ubuntu.


Lets begin...


USED Accessories:

Pre-reqs:
Before we begin we need to make sure we have all the required software on our main computer before we continue. Call the following command in your terminal.

sudo apt-get install wget pv dosfstools parted

Step One:
Identify your SD Card in Ubuntu once inserting it and bringing it into VirtualBox. Open the Terminal window and type the following.
df -h

You'll see something like the following, notice how my 4GB flash drive is referenced as /dev/sdb1 this is important and "sdb" will be used later.

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda1             6.1G  3.8G  2.1G  65% /
none                  943M  652K  942M   1% /dev
none                  949M  1.1M  948M   1% /dev/shm
none                  949M  100K  949M   1% /var/run
none                  949M     0  949M   0% /var/lock
/dev/sdb1             3.7G   32K  3.7G   1% /media/5DA5-2520

Next you'll want to download the following stable release of Ubuntu for the Beagleboard Xm with the following command. Also, it's about 108MB so it might take a little time to download on your virtualbox or ubuntu host, i'm using virtualbox.

wget http://rcn-ee.net/deb/rootfs/oneiric/ubuntu-11.10-r10-minimal-armel.tar.xz

Once that has downloaded you want to verify that the download was successful, we do this with whats called a checksum.  This is an advance algorithm that spits out a number that can be compared to verify the download was sucessful. To do so type the following by typing:
md5sum ubuntu-11.10-r10-minimal-armel.tar.xz

You must get a result that matches this!

0221ef5b014097a6a42796e54c7c365c  ubuntu-11.10-r10-minimal-armel.tar.xz

Since this is a TAR file, similar to a ZIP in windows so we must extract the files and than go to that directory
tar xJf ubuntu-11.10-r10-minimal-armel.tar.xz
cd ubuntu-11.10-r10-minimal-armel


Now that you're in the right directory its time to call the script that will partition and setup all the files on the micro SD card. Now this part its important to remember the drive name that we did above, "sdb" as this is substituted into the command below.

sudo ./setup_sdcard.sh --mmc /dev/sdb --uboot beagle_xm 


 Mine is taking about 10 mins to setup, this may vary.


After this is complete go into the disk utility found at  System -> Administration ->Disk Utility, and make sure you unmount and Safely Remove the drive (MAKE SURE YOU DO THIS EVERY TIME).





Step Two:
Now that Ubuntu has been installed on your Beagleboard XM you can test it by inserting it into the beagleboard Xm and starting it up. 

NOTE: Default username: ubuntu Password: temppwd

To check the kernel version type the following once it's booted up.
uname -r

At the time of this writing mine is version 3.1.6-x6 , now to check the version of Ubuntu type

lsb_release -a

Step Three:
Now you should have Ubuntu 11.10 installed but you will be missing the Graphical User Interface (GUI). In our case there are many options for user interfaces to install on that can be used but we're going to use XFCE because i've found it works well. Others many be used. Call the following commands to install the GUI.


sudo apt-get upgrade

sudo apt-get install gdm xfce4 xserver-xorg-video-omap3 network-manager


This may take a while to update and install, could take an hour! Once its all installed reboot and log into your new GUI Ubuntu on the Beagleboard XM!


(image may look different on BB)

(image may look different on BB)


If you have problems getting the Ethernet working on bootup try the following commands:
sudo ifconfig -a
sudo dhclient eth0
sudo ifconfig -a

Please leave feedback or email me questions.

43 comments:

  1. I'm trying this on a BeagleBone under Ubuntu 11.10. Do you have any experience with using the 'Bone?

    Everything seems to have installed apt-get'd fine but I think there's one last step...

    Do I have to do anything to get the VNC server / XFCE to start running on the BeagleBone? You don't talk about any steps for that. Am I missing something?

    When I try to VNC Viewer into the BeagleBone from my Ubuntu laptop, it gets refused on port 5900 or 5901.

    I tried "$ sudo xinit" but I get "no displays found" error

    This doesn't work either "DISPLAY=0:0 xterm &" -- "can't open display: 0:0"

    Any suggestions?

    Many thanks!
    Richard

    ReplyDelete
    Replies
    1. for vnc server try this on your board

      $ sudo apt-get install x11vnc
      this will install vnc server on your board
      to start vnc server try
      $ x11vnc -display :0 &

      now try using vnc viewer on your laptop

      Delete
    2. *****************************************************************
      This is a outdated document now. I faced lot of difficulties. Refer
      http://elinux.org/BeagleBoardUbuntu#BeagleBoard_xM

      Delete
  2. I don't have any experience with the Bone, but this link

    http://elinux.org/BeagleBoardUbuntu#Oneiric_11.10

    should provide enough details on setting it up correctly. I think the main part to change is the "bone" from beagle_xm

    sudo ./setup_sdcard.sh --mmc /dev/sdb --uboot bone



    Once you run,

    sudo apt-get install gdm xfce4 xserver-xorg-video-omap3 network-manager

    It should automatically load the GUI on the next reboot. I'm not sure on the VNC viewer into the board or the ports getting refused.

    Is your main problem getting the GUI running or do you have that working?

    ReplyDelete
  3. I am new to this beagleboard.I have installled ubuntu natty 11.04.can I know how to establish internet connections in this

    ReplyDelete
    Replies
    1. to configure Ethernet use following commands
      sudo ifconfig -a
      sudo dhclient eth0
      sudo ifconfig -a

      after this u will get connected to internet

      Delete
  4. My internet connection worked automatically when I was connected via Ethernet to my Beagleboard. Check to make sure your lights on your board are flashing green and orange and that the connections are secure. You can try running this too...

    sudo ifconfig -a

    ReplyDelete
  5. Brian,

    Hello, im new to the beagle board and linux, I used your how to, do you know id this kernel supports the LI-5M03 camera listed on the beagle board.org webpage and if so how to initialize the camera in the kernel?

    Cheers
    -Nathan

    ReplyDelete
    Replies
    1. Nathan,

      I don't know if this supports that camera. You should check the patches and see if there is one for your camera or what is needed. You will most likely need a patch and need to re-compile the kernal.

      Another great spot to check is the elinux wiki site and google forums.

      Best of luck and Cheers,
      Brian Hensley

      Delete
  6. After telling me if I'm sure to select my SD card for the process I got this lines:

    Debug: ARM rootfs: armel-rootfs-201205160638.tar
    Debug: image has initrd.img: HAS_INITRD=1
    You're missing command mkimage (consider installing package uboot-mkimage)
    You're missing command mkfs.btrfs (consider installing package btrfs-tools)
    You're missing command pv (consider installing package pv)

    Your system is missing some dependencies
    Ubuntu/Debian: sudo apt-get install uboot-mkimage wget pv dosfstools btrfs-tools parted
    Fedora: as root: yum install uboot-tools wget pv dosfstools btrfs-progs parted
    Gentoo: emerge u-boot-tools wget pv dosfstools btrfs-progs parted

    Any solutions to that?
    I'm a newbie using the Beagle Board and UNIX based OS.

    Thanks and greetings from Mexico :)

    ReplyDelete
    Replies
    1. Hello L. Esteban,

      There is a chance that your system needs these packages. I might have already had them installed on my system. If the install is recommending these I probable forgot them and I'll double check and add it to my procedure.

      The solution is to install those options. Just type the "Sudo apt-get install" ... and add those packages like it asked for. Then go back to the previous step in the install for your SD card.

      Cheers,
      Brian Hensley

      Delete
  7. Thanks alot...its the first time that I am able to run something on beagleboard on my first attempt,,

    ReplyDelete
  8. Thanks a lot for the help! My Beagleboard xM is now installing the GUI. I'm allready curious!

    ReplyDelete
    Replies
    1. Damn... I got a "Failed to load session 'Ubuntu'". I know for sure the pass is correct, 'cause else I got the error "Authentication error". What to do now?

      Delete
    2. try another session, use XFCE session rather than ubuntu session if u have it. i think it may works

      Delete
  9. i seem to have a problem with the keyboard here,

    the keyboard just doesn't work


    any idea of what i may be doing wong here

    ReplyDelete
    Replies
    1. The first thing I would guess is you have too much USB power draw. try supplying a little more current to the PI or remove any other USB devices to let all the power go to the keyboard.

      Cheers,
      Brian

      Delete
    2. got that working

      but have you got any ideas on resolving proxy settings

      Delete
  10. i want to isntall ddclient on BB-XM RevC to update IP on ddns website. i am new to this just want to know that the procedure would be same as normal PC?

    ReplyDelete
  11. is there any way to install xfce in sd card using card reader after porting,...my net is too slow i cudn't do it ,it is takin frevr...plss help...

    ReplyDelete
  12. Dear Brainhensly
    very good tutorials only sound is not working and please let us know which media player we should use for playing vedio and mp3

    ReplyDelete
  13. Hello Brian,

    Nice tutorials!
    I am working on Beagle-board XM and trying to install Ubuntu 12.10. I am trying to use S-video output on a small screen. I get a very peculiar error, the screen works fine during boot up but as soon as boot up finishes the screen display switches off (blue screen output).
    any ideas on that?

    ReplyDelete
    Replies
    1. Hi - I seem to be having issues when using S-Video on my Beagleboard XM. I've edited the uEnv.txt file in /boot/uboot to include displaymode=tv.

      It shows the bootup sequence and everything in the console, but the problem is when it loads lxde it no longer works.

      Do you know what you need to configure to ensure the x environment will work?

      Delete
  14. Worked like a charm! Was missing 3 packets at the beginning, but after installing them everything was smooth! Thanks a lot!

    ReplyDelete
  15. hey, I followed your tut, but didn't get the gui.
    can u tell me whats the error?

    ReplyDelete
  16. am not familiar with beagleboard.just a starter.while porting ubuntu,wget http://rcn-ee.net/deb/rootfs/oneiric/ubuntu-11.10-r5-minimal-armel.tar.xz
    shows n error.

    ReplyDelete
    Replies
    1. The link probable changed. try looking in his website folders for the right link and the latest file. I'll update my blog soon...

      Cheers,
      Brian

      Delete
  17. I cannot connect to the internet even after executing the commands given above ...
    even my Ethernet lights are not flashing what is the problem ???

    ReplyDelete
    Replies
    1. no internet lights... try pushing it in harder, or try a different cable. what are you connecting it too.... make sure its your router and not your computer. but really either one should turn your lights on.

      Cheers,
      Brian

      Delete
  18. i m connecting my router cable to beagle board but its not working...
    when i boot ubuntu 12.10 on beagle-board it works fine without any command ...but whan i installed ubuntu 9.04 or ubuntu 10.04 it is not really working...
    my all components are working fine i.e ethernet cable ,router etc...
    and i have installed these lower versions by the same method u described above...
    i have used same script for installing ubuntu 9.04/10.04 on beagleboard xm ...is ther any problem with it ? i m installing these lower versions coz 12.10 is to heavy for 1Ghz processor as i want to run video on beagleboard from camera it becomes to slow ...
    thanx for ur rply ...
    thanx alot ...:)

    ReplyDelete
    Replies
    1. Hi,

      I've never tried 9.04 or 10.04 Ubuntu versions on my beagleboard XM. And i'm not sure they would be better for you. I would recommend you look for a version already designed for it, and make sure if you want a GUI interface that you choose one that is known to have fast reaction times. I personally like LXDE which is a light weight desktop or XFCE. Check out them on 12.10 you might like it.

      http://www.brianhensley.net/2013/01/beagleboard-xm-how-to-install-ubuntu.html

      Cheers,
      Brian

      Delete
  19. Replies
    1. the above u replied was mine...
      thanx for ur reply ...
      actually i installed GUI XFCE on my 12.10 but it was slow...i wanna do image processing in real time on it and it would make it more slow for me to work on imageprocessing in realtime thats why i m chooing a lower version coz it would b lighter than 12.10 ...

      Delete
  20. Hi Brian,
    I'm working ubuntu 12.10 on Beagleboard xM . Do I use the serial terminal using booting with beagleboard as same as Angstrom image?

    ReplyDelete
  21. just curious, why would you need gnome , isnt xfce4 enough to provide a functional window manager?

    ReplyDelete
  22. Hi all

    Has anyone managed to get sound working on thier beagleboard? I've followed all the above steps but no luck on the sounds

    ReplyDelete
  23. Hi Boss Need ur help !!!
    Getting this ERROR at last no idea pls help??
    Downloading Device's Bootloader
    -----------------------------
    attempting to use rcn-ee.net for dl files [10 second time out]...
    http://rcn-ee.net/deb/tools/latest/bootloader:
    2013-09-30 07:24:11 ERROR 404: Not Found.
    rcn-ee.net down, switching to slower backup mirror
    -----------------------------
    http://rcn-ee.homeip.net:81/dl/mirrors/deb/tools/latest/bootloader:
    2013-09-30 07:24:12 ERROR 404: Not Found.
    ERROR: Network Failure, are you connected to the internet?
    Unable to download bootloader from main and backup server.

    kindly help me PLS... :(

    ReplyDelete
    Replies
    1. I have my net connection active..also.try it..

      Delete
  24. I am trying to run Ununtu using Beagleboard XM. I get the following message when I run the setup_sdcard script:

    I see...
    fdisk -l:
    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    Disk /dev/sdc: 3965 MB, 3965190144 bytes

    lsblk:
    NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
    sda 8:0 0 465.8G 0 disk
    ├─sda1 8:1 0 462G 0 part /
    ├─sda2 8:2 0 1K 0 part
    └─sda5 8:5 0 3.8G 0 part [SWAP]
    sdc 8:32 1 3.7G 0 disk
    ├─sdc1 8:33 1 48M 0 part /media/saurabh/boot
    └─sdc2 8:34 1 3.7G 0 part /media/saurabh/rootfs

    Are you 100% sure, on selecting [/dev/sdc] (y/n)? y

    Debug: image has armv7 multi arch kernel support: v3.11.1-armv7-x14
    Debug: image has bone device tree kernel support: v3.8.13-bone28
    Debug: image has omap kernel support: v3.7.10-x13
    Note: [--dtb omap3-beagle-xm] now replaces [--uboot beagle_xm]
    -----------------------------
    info: [conf_boot_startmb] undefined using default value: 1
    info: [conf_boot_endmb] undefined using default value: 64
    Debug: ARM rootfs: armhf-rootfs-ubuntu-raring.tar
    Debug: image has initrd.img:
    Debug: image has device tree:

    Downloading Device's Bootloader
    -----------------------------

    After this the download stops and the script exists. I am having my internet connection active.
    Can you please help me with this. Thank you.

    Do I need to add rcn-ee.net as a source or something or may be bypass the proxy ?

    ReplyDelete
  25. Can you please guide me how to install archlinuxarm with openbox gui in beagleboard? I shall remain thankful to you for this forever.

    ReplyDelete
  26. Hi Brian

    can this procedure be used to setup the BeagleBoard (non XM )?

    Thanks in advance.
    Oscar

    ReplyDelete
  27. Hi,

    I guess this is not valid anymore as the wget instruction to fetch the Image is not working . I guess they have removed the packages from the rcn-ee.net

    ReplyDelete